Back to overview
Resolved
Some services are down
Jul 26, 2026 at 3:45pm UTC
Affected services
ousama.dev
Resolved
Jul 26, 2026 at 3:45pm UTC
The server is being updated to run the website, we are moving the website to another server.
Affected services